package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)^.*100\s*%.*?\r?\n`)
var str = []byte(`Verification 97% complete.
Verification 98% complete.
Verification 98% complete.
Verification 99% complete.
Verification 99% complete.
Verification 100% complete.
Foo
bar
baz`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}