use strict;
my $str = 'Verification 97% complete.
Verification 98% complete.
Verification 98% complete.
Verification 99% complete.
Verification 99% complete.
Verification 100% complete.
Foo
bar
baz';
my $regex = qr/^.*100\s*%.*?\r?\n/sip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";