re = /^.*100\s*%.*?\r?\n/i
str = 'Verification 97% complete.
Verification 98% complete.
Verification 98% complete.
Verification 99% complete.
Verification 99% complete.
Verification 100% complete.
Foo
bar
baz'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result