// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?|(((8|\+7)[\- ]?)?(\(?\d{3}\)?[\- ]?)?[\d\- ]{7,10}|(38\(026\)123-45-67)|\+380 123 45 67))$").unwrap();
let string = "+79261234567
89261234567
79261234 567
+380 123 45 67
38(026)123-45-67
9261234567
79261234567
(495)1234567
(495) 123 45 67
89261234567
8-926-123-45-67
8 927 1234 234
8 927 12 12 888
8 927 12 555 12
8 927 123 8 123
Пример с условием
/(?|(candy)|(kiss)|(berry))/g
A candy, kiss, or even a berry is delicious.
$1 =candykissberry ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}