#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)assorted-customer-choices\/(?!03c4cbb1-7376-4141-b7c0-aed1fd0b779b$).*$"
Local $sString = "assorted-customer-choices/03c4cbb2-7376-4141-b7c0-aed1fd0b779a" & @CRLF & _
"assorted-customer-choices/03c4cbb1-7376-4141-b7c0-aed1fd0b779b"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")