const regex = /assorted-customer-choices\/(?!03c4cbb1-7376-4141-b7c0-aed1fd0b779b$).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('assorted-customer-choices\\\/(?!03c4cbb1-7376-4141-b7c0-aed1fd0b779b$).*$', 'gm')
const str = `assorted-customer-choices/03c4cbb2-7376-4141-b7c0-aed1fd0b779a
assorted-customer-choices/03c4cbb1-7376-4141-b7c0-aed1fd0b779b`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}