#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d*)\d{2}\b"
Local $sString = "1091 foo address" & @CRLF & _
"" --> "10XX BLOCK foo address"" & @CRLF & _
"1016 foo 1010 address" & @CRLF & _
"" --> "10XX BLOCK foo 1010 address"" & @CRLF & _
"foo 1081 address" & @CRLF & _
"" --> "foo 1081 address"" & @CRLF & _
"10 bar address" & @CRLF & _
"" --> "XX BLOCK bar address"" & @CRLF & _
"8 baz address" & @CRLF & _
"" --> "8 baz address""
Local $sSubst = "$1XX BLOCK"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)