re = /^(\d*)\d{2}\b/m
str = '1091 foo address
" --> "10XX BLOCK foo address"
1016 foo 1010 address
" --> "10XX BLOCK foo 1010 address"
foo 1081 address
" --> "foo 1081 address"
10 bar address
" --> "XX BLOCK bar address"
8 baz address
" --> "8 baz address"'
subst = '$1XX BLOCK'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result