// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d*)\d{2}\b").unwrap();
let string = "1091 foo address
\" --> \"10XX BLOCK foo address\"
1016 foo 1010 address
\" --> \"10XX BLOCK foo 1010 address\"
foo 1081 address
\" --> \"foo 1081 address\"
10 bar address
\" --> \"XX BLOCK bar address\"
8 baz address
\" --> \"8 baz address\"";
let substitution = "$1XX BLOCK";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}