import Foundation
let pattern = #"^(\d*)\d{2}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1091 foo address
" --> "10XX BLOCK foo address"
1016 foo 1010 address
" --> "10XX BLOCK foo 1010 address"
foo 1081 address
" --> "foo 1081 address"
10 bar address
" --> "XX BLOCK bar address"
8 baz address
" --> "8 baz address"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1XX BLOCK"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)