using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"kod:[ ]([a-zA-Z]*)[ ]";
string input = @"sf sdf sdf kod: ahoj sdfsdfsf
kod:
kod: ahoj aaa
kod: ahoj
ahoj kod:";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}