using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<identity>https:\/\/foobar\.com\/.*?(?=ending)ending?)";
string input = @"https://foobar.com/bla-bla-bla-bla-ending
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}