$re = '/(?<identity>https:\/\/foobar\.com\/.*?(?=ending)ending?)/';
$str = 'https://foobar.com/bla-bla-bla-bla-ending
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);