using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^foo\.bar\.lib(?:\..*)?(?<!unsafe)\.\w+$";
string input = @"foo.bar.lib.Main
foo.bar.lib.impl.Main
foo.bar.libxxx.Main
foo.bar.libxxx.impl.Main
foo.bar.lib.unsafe.Unsafe
foo.bar.lib.unsafe.Unsafe
foo.bar.libxxx.unsafe.Unsafe
foo.bar.lib.util.Main
foo.bar.lib.impl.util.Main
foo.bar.libxxx.util.Main
foo.bar.libxxx.impl.util.Main
foo.bar.lib.util.unsafe.Unsafe
foo.bar.lib.util.unsafe.Unsafe
foo.bar.libxxx.util.unsafe.Unsafe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}