using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z][a-z]+)|([A-Z]+(?=[A-Z]))|(\d+)";
string substitution = @"$1 $2 $3";
string input = @"SomeEquipmentHere
ABSBrakes
CDRadio
Valve14";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}