# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/books(\\/(.*))?$/\/ebooks$1/gm;t' <<< "/books
/books/economic-genious
/books/flight-mechanics
/books123
/books/abc/test"