#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(0[1-9]|[12]\d|3[0-1])[\./]([0[1-9]|1[0-2])[\./](196[1-9]|19[7-9]\d|20\d\d|2100)"
Local $sString = "01.12.1990" & @CRLF & _
"04.05.2000" & @CRLF & _
"31.12.2010" & @CRLF & _
"31.12.1980" & @CRLF & _
"31.12.1989" & @CRLF & _
"31.12.1999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")