import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0[1-9]|[12]\\d|3[0-1])[\\./]([0[1-9]|1[0-2])[\\./](196[1-9]|19[7-9]\\d|20\\d\\d|2100)";
final String string = "01.12.1990\n"
+ "04.05.2000\n"
+ "31.12.2010\n"
+ "31.12.1980\n"
+ "31.12.1989\n"
+ "31.12.1999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}