re = /(0[1-9]|[12]\d|3[0-1])[\.\/]([0[1-9]|1[0-2])[\.\/](196[1-9]|19[7-9]\d|20\d\d|2100)/m
str = '01.12.1990
04.05.2000
31.12.2010
31.12.1980
31.12.1989
31.12.1999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end