using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+[/]\d+[/]\d+[-\s\.]*\d+[/]\d+[/]\d+)";
string input = @"string1 = '11/13/2019 - 11/13/2019'
string2 = '11/14/2019 11/14/2019'
string3 = '01/21/2019. . 11/20/2019'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}