use strict;
my $str = 'string1 = \'11/13/2019 - 11/13/2019\'
string2 = \'11/14/2019 11/14/2019\'
string3 = \'01/21/2019. . 11/20/2019\'';
my $regex = qr/(\d+[/]\d+[/]\d+[-\s\.]*\d+[/]\d+[/]\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}