#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?<=%\()|(?<={))([^\){]*)(?=[}\)])"
Local $sString = "# Example functions using print that we want to extract the substitution args from" & @CRLF & _
"" & @CRLF & _
" def Initialise(self):" & @CRLF & _
" print '# NDOverlayConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, NOverlays, maxBuffers, maxMemory, priority, stackSize, maxThreads)'" & @CRLF & _
" print 'NDOverlayConfigure("%(PORT)s", %(QUEUE)d, %(BLOCK)d, "%(NDARRAY_PORT)s", %(NDARRAY_ADDR)s, %(NOverlays)d, 0, 0, 0, 0, %(MAX_THREADS)d)' % self.__dict__" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" def Initialise(self):" & @CRLF & _
" print('# NDROIStatConfigure(portName, queueSize, blockingCallbacks, '" & @CRLF & _
" 'NDArrayPort, NDArrayAddr, maxROIs, maxBuffers, maxMemory,'" & @CRLF & _
" 'priority', 'stackSize', 'maxThreads')" & @CRLF & _
" print('NDROIStatConfigure("{PORT}", {QUEUE}, {BLOCK}, '" & @CRLF & _
" '"{NDARRAY_PORT}", {NDARRAY_ADDR}, {MAX_ROIS}, '" & @CRLF & _
" '0, 0, 0, 0, {MAX_THREADS})'.format(**self.__dict__))" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" def Initialise(self):" & @CRLF & _
" print '# NDStdArraysConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, maxBuffers, maxMemory, priority, stackSize, maxThreads)'" & @CRLF & _
" print 'NDStdArraysConfigure("%(PORT)s", %(QUEUE)d, %(BLOCK)d, "%(NDARRAY_PORT)s", %(NDARRAY_ADDR)s, 0, 0, 0, 0, %(MAX_THREADS)d)' % self.__dict__" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")