import Foundation
let pattern = #"(?:(?<=%\()|(?<={))([^\){]*)(?=[}\)])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Example functions using print that we want to extract the substitution args from
def Initialise(self):
print '# NDOverlayConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, NOverlays, maxBuffers, maxMemory, priority, stackSize, maxThreads)'
print 'NDOverlayConfigure("%(PORT)s", %(QUEUE)d, %(BLOCK)d, "%(NDARRAY_PORT)s", %(NDARRAY_ADDR)s, %(NOverlays)d, 0, 0, 0, 0, %(MAX_THREADS)d)' % self.__dict__
def Initialise(self):
print('# NDROIStatConfigure(portName, queueSize, blockingCallbacks, '
'NDArrayPort, NDArrayAddr, maxROIs, maxBuffers, maxMemory,'
'priority', 'stackSize', 'maxThreads')
print('NDROIStatConfigure("{PORT}", {QUEUE}, {BLOCK}, '
'"{NDARRAY_PORT}", {NDARRAY_ADDR}, {MAX_ROIS}, '
'0, 0, 0, 0, {MAX_THREADS})'.format(**self.__dict__))
def Initialise(self):
print '# NDStdArraysConfigure(portName, queueSize, blockingCallbacks, NDArrayPort, NDArrayAddr, maxBuffers, maxMemory, priority, stackSize, maxThreads)'
print 'NDStdArraysConfigure("%(PORT)s", %(QUEUE)d, %(BLOCK)d, "%(NDARRAY_PORT)s", %(NDARRAY_ADDR)s, 0, 0, 0, 0, %(MAX_THREADS)d)' % self.__dict__
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)