# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<td>[A-Z0-9-]+<\/td>"
test_str = ("<table class=\"stripeMe\">\n"
" <tbody>\n"
" <tr>\n"
" <th>Image</th>\n"
" <th>Part#</th>\n"
" <th>Original#</th>\n"
" <th>Description</th>\n"
" </tr>\n"
" <tr class=\"alt\">\n"
" <td>\n"
" <a href=\"/item/8438657/High_Capacity/AC-C27/18_TO_20_VOLT_65_WATT_AC_ADAPT\"><img width=\"75\" height=\"75\" title=\"AM11X-2719 18 TO 20 Volt 65 Watt AC Adapter\" src=\"/shop/images/image.php?img=BAT\\8438657.jpg&thumbnail=Y\"></a>\n"
" </td>\n"
" <td><a title=\"AM11X-2719 18 TO 20 Volt 65 Watt AC Adapter\" href=\"/item/8438657/High_Capacity/AC-C27/18_TO_20_VOLT_65_WATT_AC_ADAPT\">AC-C27</a></td>\n"
" <td>TR82J</td>\n"
" <td>18 TO 20 Volt 65 Watt AC Adapter</td>\n"
" </tr>\n"
" <tr class=\"\">\n"
" <td>\n"
" <a href=\"/item/10242499/High_Capacity/DRAC90B/DURACELL_90W_19V_UNIVERSAL_NOT\"><img width=\"75\" height=\"75\" title=\"AM11X-2719 Duracell 90W 19V Universal Notebook AC Adapter\" src=\"/shop/images/no_picture_thumb.jpg\"></a>\n"
" </td>\n"
" <td><a title=\"AM11X-2719 Duracell 90W 19V Universal Notebook AC Adapter\" href=\"/item/10242499/High_Capacity/DRAC90B/DURACELL_90W_19V_UNIVERSAL_NOT\">DRAC90B</a></td>\n"
" <td>331-0536</td>\n"
" <td>Duracell 90W 19V Universal Notebook AC Adapter</td>\n"
" </tr>\n"
" </tbody>\n"
"</table>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.