$re = '/(?i)(https\:\/\/){1}((t\.me|telegram\.me)\/){1}(joinchat\/)?(([\+\_\-a-zA-Z0-9])+)$/m';
$str = 'join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://telegram.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/joinchat/GsyKEdRaawQ3ZDc8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);