import Foundation
let pattern = #"(?i)(https\:\/\/){1}((t\.me|telegram\.me)\/){1}(joinchat\/)?(([\+\_\-a-zA-Z0-9])+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/+8Wkkhz_JSIJjN2Rk
join https://telegram.me/+8Wkkhz_JSIJjN2Rk
join https://t.me/joinchat/GsyKEdRaawQ3ZDc8
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)