const regex = /^(?:Manifest.*|.*\.[sS][iI][gG]|.*\.[tT][aA][rR]|[0-9]{2}-[0-9]{2}.*|first.*|latest.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:Manifest.*|.*\\.[sS][iI][gG]|.*\\.[tT][aA][rR]|[0-9]{2}-[0-9]{2}.*|first.*|latest.*)$', 'gm')
const str = `Manifest.MoM.tar
Manifest-random-pack
Manifest.full
latest
latest_version
latest.sig
latest_version.sig
first
first.sig
10-20-randomnumber
randomnumber.tar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}