use strict;
my $str = 'Manifest.MoM.tar
Manifest-random-pack
Manifest.full
latest
latest_version
latest.sig
latest_version.sig
first
first.sig
10-20-randomnumber
randomnumber.tar';
my $regex = qr/^(?:Manifest.*|.*\.[sS][iI][gG]|.*\.[tT][aA][rR]|[0-9]{2}-[0-9]{2}.*|first.*|latest.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}