import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[A-Z0-9/.-]{5,}\\s).*";
final String string = "Test ABC123 Test\n"
+ "ABC123 Test\n"
+ "Test ABC123\n"
+ "Test ABC-123 Test\n"
+ "ABC-123 Test\n"
+ "Test ABC-123\n"
+ "Test ABC/123 Test\n"
+ "ABC/123 Test\n"
+ "Test ABC/123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}