#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)^(\w+\s\w+(?:\s\w+)?)\s(\d{2}\.\d{2}\.\d{4})\s(\d+)$"
Local $sString = "Иванов Иван Иванович 01.01.1970 353" & @CRLF & _
"Иванов Иван 01.01.1970 353"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")