package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+\s\w+(?:\s\w+)?)\s(\d{2}\.\d{2}\.\d{4})\s(\d+)$`)
var str = `Иванов Иван Иванович 01.01.1970 353
Иванов Иван 01.01.1970 353`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}