use strict;
my $str = 'Иванов Иван Иванович 01.01.1970 353
Иванов Иван 01.01.1970 353';
my $regex = qr/^(\w+\s\w+(?:\s\w+)?)\s(\d{2}\.\d{2}\.\d{4})\s(\d+)$/ump;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}