using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+ (?=\[\d+\]\.txt$)";
string substitution = @"";
string input = @"ABC [1].txt
ABC [2].txt
ABC [10].txt";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}