const regex = new RegExp('^.+ (?=\\[\\d+\\]\\.txt$)', 'gmi')
const str = `ABC [1].txt
ABC [2].txt
ABC [10].txt`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);