using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?![A-Z]+\b)[a-zA-Z0-9_{}]*\b";
string input = @"VarWithCapitals
variable
var_with_snake_case
var_with_{curly}_braces
Var_with_The_{kitchen123}_Sink
CMD
DO
WHILE
ENDWHILE
FOR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}