re = /\b(?![A-Z]+\b)[a-zA-Z0-9_{}]*\b/m
str = 'VarWithCapitals
variable
var_with_snake_case
var_with_{curly}_braces
Var_with_The_{kitchen123}_Sink
CMD
DO
WHILE
ENDWHILE
FOR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end