package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{1,2})\s*-\s*(\d{1,2})`)
var str = `PERU
Liga 2
]
Final
Santa Rosa
0
-
3
Molinos El Pirata
73
Chavelines
1
-
0
Deportivo Coopsol
20:30
Comerciantes Unidos
-
Juan Aurich
22:45
Santos FC
-
Huaral
90+1
Pogon Szczecin
2
-
0
Stal Mielec
live
20:30
Plock
-
Gornik Z.
21:15
Farense
-
Maritimo
`
var substitution = "$1-$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}