import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,2})\\s*-\\s*(\\d{1,2})";
final String string = "PERU\n"
+ "Liga 2\n"
+ "]\n"
+ "Final\n"
+ "Santa Rosa\n\n"
+ "0\n"
+ " - \n"
+ "3\n\n"
+ "Molinos El Pirata\n\n"
+ "73 \n"
+ "Chavelines\n\n"
+ "1\n"
+ " - \n"
+ "0\n\n"
+ "Deportivo Coopsol\n\n"
+ "20:30\n"
+ "Comerciantes Unidos\n\n"
+ "-\n\n"
+ "Juan Aurich\n"
+ "22:45\n"
+ "Santos FC\n\n"
+ "-\n\n"
+ "Huaral\n\n"
+ "90+1 \n"
+ "Pogon Szczecin\n\n"
+ "2\n"
+ " - \n"
+ "0\n\n"
+ "Stal Mielec\n\n"
+ "live\n"
+ "20:30\n"
+ "Plock\n\n"
+ "-\n\n"
+ "Gornik Z.\n\n"
+ "21:15\n"
+ "Farense\n\n"
+ "-\n\n"
+ "Maritimo\n";
final String subst = "$1-$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}