re = /(\d{1,2})\s*-\s*(\d{1,2})/m
str = 'PERU
Liga 2
]
Final
Santa Rosa
0
-
3
Molinos El Pirata
73
Chavelines
1
-
0
Deportivo Coopsol
20:30
Comerciantes Unidos
-
Juan Aurich
22:45
Santos FC
-
Huaral
90+1
Pogon Szczecin
2
-
0
Stal Mielec
live
20:30
Plock
-
Gornik Z.
21:15
Farense
-
Maritimo
'
subst = '$1-$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result