// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{1,2})\s*-\s*(\d{1,2})").unwrap();
let string = "PERU
Liga 2
]
Final
Santa Rosa
0
-
3
Molinos El Pirata
73
Chavelines
1
-
0
Deportivo Coopsol
20:30
Comerciantes Unidos
-
Juan Aurich
22:45
Santos FC
-
Huaral
90+1
Pogon Szczecin
2
-
0
Stal Mielec
live
20:30
Plock
-
Gornik Z.
21:15
Farense
-
Maritimo
";
let substitution = "$1-$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}