$re = '/<img([\w\W]+?)>/';
$str = '<img src="test.jpg"><p>some text</p><img src="test.jpg">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);