$re = '/[Ss]plit[ -]“?[Ss]”?+(?<!Split “S”)/m';
$str = 'split “S” Split-S Split S Split S, but not Split “S”';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);