$re = '/^.*?\b(?!From|To|Subj(ject)?|Ref(erences?)?)(?=\w{3,}( \d+)?:)/s';
$str = 'Text of variable length spread across several lines Serialization-type text separated by colons A date
From: One line of text To: One or more lines Subject: One or more lines References: One or more lines
From: One line of text To: One
or
more
lines Subject: One or more lines References: One or more lines
From: One line of text To: One or more lines Subject: No references.
From: One line of text To: One or more lines Subject: One
or
more
lines
References: One or more lines
Paragraph 1 Title: A paragraph
Paragraph 2 Title: Another paragraph';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;