#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:#?\d*|#[#*])$"
Local $sString = "我想要写匹配如下5种格式字符串的正则表达式:" & @CRLF & _
"1.数字" & @CRLF & _
"2.数字#" & @CRLF & _
"3.数字##" & @CRLF & _
"4.数字#*" & @CRLF & _
"5.数字#数字" & @CRLF & _
"" & @CRLF & _
"12334#" & @CRLF & _
"12334##" & @CRLF & _
"12334#*" & @CRLF & _
"12334#12367" & @CRLF & _
"123123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")