const regex = /(?<=\bid="[^"]*?)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\bid="[^"]*?)\\s', 'gm')
const str = `this is a sample id="aaa bbb ccc" name="abc abc"`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);