package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((\(*(?:[^)(]*|\([^)]*\))*\)*)\)`)
var str = `Foo ( test1 test2 )
test2 Bar ( test1 t3() test2 )
((("Fdsfds")))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}