package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]+.*[A-Z].*\d+$`)
var str = `stroidom11
82sizFova28091982
Lyubyatin90977Bishop
LyubyatinBishop90977
SherefetdinovaMissalina193`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}