import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]+.*[A-Z].*\\d+$";
final String string = "stroidom11\n"
+ "82sizFova28091982\n"
+ "Lyubyatin90977Bishop\n"
+ "LyubyatinBishop90977\n"
+ "SherefetdinovaMissalina193";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}