import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\<\\d+\\>(?<last_seen>\\w+\\s+\\d+\\s+\\d+:\\d+:\\d+).*namespace_name\\=(?<namespace_name>[^,]+),\\s+container_name\\=(?<container_name>[^,]+),\\s+pod_name\\=(?<pod_name>[^,]+),\\s+message\\=(?<message1>[^\\]]+).*object\\=\\\"(?<cluster_namespace>[^\\/]+)\\/(?<cluster_podname>[^\\\"]+)\\\"\\s+kind\\=\\\"(?<kind>[^\\\"]+)\\\"\\s+apiVersion\\=\\\"(?<apiVersion>[^\\\"]+)\\\"\\s+type\\=\\\"(?<type>[^\\\"]+)\\\"\\s+reason\\=\\\"(?<reason>[^\\\"]+)\\\"\\s+message\\=\\\"(?<message2>[^\\\"]+)\\\"";
final String string = "<135>Dec 30 06:59:07 9000n2.nodes.com kubernetes.var.log.containers.ku: namespace_name=openshift-kube-controller-manager, container_name=kube-controller-manager, pod_name=kube-controller-manager-9000n2.nodes.com, message=I1230 06:58:56.139184 1 event.go:291] \"Event occurred\" object=\"openshift-logging/elasticsearch-im-infra\" kind=\"CronJob\" apiVersion=\"batch/v1beta1\" type=\"Warning\" reason=\"FailedNeedsStart\" message=\"Cannot determine if job needs to be started: too many missed start time (> 100). Set or decrease .spec.startingDeadlineSeconds or check clock skew\"\n"
+ "<135>Dec 30 06:59:07 9000n2.nodes.com kubernetes.var.log.containers.ku: namespace_name=openshift-kube-controller-manager, container_name=kube-controller-manager, pod_name=kube-controller-manager-9000n2.nodes.com, message=I1230 06:58:56.133312 1 event.go:291] \"Event occurred\" object=\"openshift-logging/elasticsearch-im-audit\" kind=\"CronJob\" apiVersion=\"batch/v1beta1\" type=\"Warning\" reason=\"FailedNeedsStart\" message=\"Cannot determine if job needs to be started: too many missed start time (> 100). Set or decrease .spec.startingDeadlineSeconds or check clock skew\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}