#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "輸入你的規則"
Local $sString = "# 題目名稱" & @CRLF & _
"" & @CRLF & _
"# 題目說明區塊" & @CRLF & _
"" & @CRLF & _
"#欲測試資料集" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# 應配對結果(亮色區塊)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")